Codeception for Symfony 5

If you try to install Symfony 5 (full) and Codeception in standard way by running composer commands like below:

composer create-project symfony/website-skeleton PROJECT_NAME;

composer require codeception/codeception;

After running a second line you'll probably get the following error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - codeception/codeception 3.1.2 requires symfony/finder >=2.7 <5.0 -> no matching package found.
    - codeception/codeception 3.1.1 requires symfony/finder >=2.7 <5.0 -> no matching package found.
    - codeception/codeception 3.1.0 requires symfony/finder >=2.7 <5.0 -> no matching package found.
    - Installation request for codeception/codeception ^3.1 -> satisfiable by codeception/codeception[3.1.0, 3.1.1, 3.1.2].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

We need to either use Codeception >= 4.0 or Symfony < 5.0, because for now Codeception doesn't work with Symfony5